Results 1 to 7 of 7

Thread: FLAC to MP3 transcoding - just 32kb/s!

  1. #1

    FLAC to MP3 transcoding - just 32kb/s!

    I mainly use KRR for pushing music (in FLAC format) to a Denon network media player and it is fantastic.

    However, I have a query about other PCs at home streaming music over the LAN from KRR. They are Windows 8.1 with Windows Media Player (WMP). KRR decides that the FLAC files should be transcoded, which seems sensible because WMP doesn't do FLAC natively. However, it decides to create 32kb/s MP3 files, which is a very low quality level and obviously sounds terrible. In Device Definition > General I set the "Device" dropdown to "Microsoft Media Player" and then "Microsoft Media Player 8" (it was on "Default Device") but that has made no difference - transcoding of the FLAC files still produces 32kb/s MP3 files.

    Why does KRR do this please? Is there any way to make it transcode at a higher quality, e.g. to produce 192kb/s MP3s?

    I switched logging on and this is what resulted, you can see the FFmpeg command in line 2 with the 32kb/s switch (-b:a 32000):

    Code:
    2015-03-26T16:53:02.567Z [CThreadTranscoder::Start] (5344) FINEST: Started transcoding thread
    2015-03-26T16:53:02.567Z [CThreadTranscoder::Run] (6116) INFO: Starting transcoding: "C:\Program Files\KooRaRoo Media\ffmpeg.exe"  -i "C:\Nick\big\music\ripped\contemporary\AC,DC\Ballbreaker\01 Hard as a Rock.flac"   -y   -c:a libmp3lame  -b:a 32000  -ar 44100  -ac 2  -map 0:0  -dn -f mp3   "C:\Users\Public\Documents\KooRaRooMedia\KooRaRoo_Transcoding\mp3_mp3\395-40.krra"
    2015-03-26T16:53:02.697Z [CThreadTranscoder::SetOutput] (4856) INFO: ffmpeg version N-60988-g52d928d Copyright (c) 2000-2014 the FFmpeg developers
      built on Mar  1 2014 10:34:03 with gcc 4.8.0 (GCC)
      configuration: --disable-shared --enable-static --arch=x86_64 --target-os=mingw32 --cross-prefix=/home/dennis/cc/mingw-w64-x86_64/bin/x86_64-w64-mingw32- --pkg-config=pkg-config --enable-gpl --enable-libx264 --enable-avisynth --enable-libxvid --enable-libmp3lame --enable-version3 --enable-zlib --enable-libopenjpeg --enable-libfreetype --enable-fontconfig --enable-libass --disable-w32threads --enable-bzlib --enable-libbluray --enable-dxva2 --enable-memalign-hack --enable-avresample --enable-runtime-cpudetect --extra-cflags=-DPTW32_STATIC_LIB --enable-libvpx
      libavutil      52. 66.100 / 52. 66.100
      libavcodec     55. 52.102 / 55. 52.102
      libavformat    55. 33.100 / 55. 33.100
      libavdevice    55. 10.100 / 55. 10.100
      libavfilter     4.  2.100 /  4.  2.100
      libavresample   1.  2.  0 /  1.  2.  0
      libswscale      2.  5.101 /  2.  5.101
      libswresample   0. 18.100 /  0. 18.100
      libpostproc    52.  3.100 / 52.  3.100
    Input #0, flac, from 'C:\Nick\big\music\ripped\contemporary\AC,DC\Ballbreaker\01 Hard as a Rock.flac':
      Metadata:
        ARTIST          : AC/DC
        TITLE           : Hard as a Rock
        ALBUM           : Ballbreaker
        DATE            : 1995
        track           : 01
        GENRE           : Rock
        BAND            : AC/DC
        album_artist    : AC/DC
        COMPOSER        : Angus Young
        disc            : 1
        TOTALDISCS      : 1
        TOTALTRACKS     : 11
      Duration: 00:04:31.40, bitrate: 981 kb/s
        Stream #0:0: Audio: flac, 44100 Hz, stereo, s16
        Stream #0:1: Video: mjpeg, yuvj420p(pc), 1417x1417 [SAR 96:96 DAR 1:1], 90k tbr, 90k tbn, 90k tbc
        Metadata:
          comment         : Cover (front)
    Output #0, mp3, to 'C:\Users\Public\Documents\KooRaRooMedia\KooRaRoo_Transcoding\mp3_mp3\395-40.krra':
      Metadata:
        TPE1            : AC/DC
        TIT2            : Hard as a Rock
        TALB            : Ballbreaker
        TDRL            : 1995
        TRCK            : 01
        TCON            : Rock
        BAND            : AC/DC
        TPE2            : AC/DC
        TCOM            : Angus Young
        TPOS            : 1
        TOTALDISCS      : 1
        TOTALTRACKS     : 11
        TSSE            : Lavf55.33.100
        Stream #0:0: Audio: mp3 (libmp3lame), 44100 Hz, stereo, s16p, 32 kb/s
    Stream mapping:
      Stream #0:0 -> #0:0 (flac -> libmp3lame)
    Press [q] to stop, [?] for help

  2. #2
    Hi KRR Team, any thoughts on this please? I notice you've replied to a number of other threads since I posted this query, so I wondered if you could get around to commenting soon if you get chance please?

  3. #3
    Still no reply from KRR Team Have I done something wrong? Is this the correct place to ask? If it's any help, I have paid for KRR and I'm very happy with it!

  4. #4
    Super Moderator KRR Team's Avatar
    Join Date
    Mar 2014
    Posts
    201
    Hi
    Sorry for the delay in our reply.
    What device do you use?
    You may try to change the device profile in order to control the default transcoding.
    Please advise and we will check

  5. #5
    Thanks for replying KRR Team

    All the information you ask for should be in my original post. It is when Windows 8.1 laptops using Windows Media Player access KRR on my PC over the LAN. The device was originally set to "Default Device" but I changed it to "Microsoft Media Player". This made no difference. The FLAC files on my PC are transcoded to MP3s (which is good) at just 32kb/s (which is not good!).

    Is it possible for me to change the settings somewhere so that it will transcode at 192kb/s or 128kb/s or similar?

  6. #6
    Hi, any update on this please? I think it should be simple - I basically want to change the -b switch passed to FFmpeg so I can increase the bitrate to 128 or 192. How can this be done please?

  7. #7
    Yoo-hoo, is there anybody from KRR here any more? I guess not, which is a real shame because it's a great product.

    Surely this issue is easy to fix - just tell me how I can change the value passed to FFmpeg with the -b switch, or modify the code to allow this.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •