Results 1 to 6 of 6

Thread: Very odd problem all of a sudden...

  1. #1

    Question Very odd problem all of a sudden...

    Bare with me - this has been doing my head in and I'm no further forward.

    I've used KRR for some years, and have recently upgraded to 2.5 - 2.4 has been working well for the last 12 months and 2.5 has also worked OK for the last few days... and then yesterday it started.

    KRR runs on a Windows 7 Ultimate SP1 machine - 32 bit and it streams to a number of devices (Smart TVs, Xbox One, other Windows PCs, WDTV Live, etc.), all pretty much OK.

    In my lounge I have an 8 port switch, with a HomePlug linking the lounge network to the main KRR server network. The lounge 8 port switch has my Panasonic TXP42GT60B TV on it and an Xbox One.

    The Xbox One can see KRR, browse files/folders and play everything fine... no problem.

    ... and up until recently the Panasonic could do the same. However, right now it can't see ANY DLNA server (well, it can't see KRR or PS3MS - though strangely, it can see Logitech Media Server running on the same box). I've started running PS3MS purely for test purposes. The Xbox One can see them all - the Panasonic can't see any, except the Logitech server (which I guess is also some form of DLNA server - though I have it to serve my Squeezeboxes with audio).

    If I use the Panasonic "Media Server" app (odd name for a client, but there you go) - it doesn't even report KRR or PS3MS as existing. (Within the PS3MS logs I can see "INFO 2015-03-15 19:59:42.286 [UPNPHelper] No IP filter specified, access granted to /" - which is the TV IP address, but no other mention of it)... I haven't tried decyphering KRR logs yet - but it seems a generic issue anyway.

    If I use the Panasonic "Web browser" app and connect to the KRR server on port 53180 (with /html, etc.) then I can see and navigate through the browser based KRR menus without any problem.

    I've tried everything...

    I've reinstalled KRR, reinstalled and scrapped the DB, rolled back recent Windows Updates (I'm still concerned that it's something to do with a setting that one of these has applied - that a System Restore point hasn't recovered), rebooted everything (switches, bridges, TVs, routers, servers, etc.).

    I've tried enabling Windows Media Player's DLNA server, and HomeGroups and all that rubbish - nothing.

    I have had a couple of BSODs recently, and the only real thing that has changed is KRR 2.5 - which seems odd... and these problems seem to have started after the BSODs started.

    Currently I have all firewalls turned off on the KRR box, still nothing. Although the network that it's connected to was already a "Home" one, I've reset it to a "Home" one just in case.

    It's crazy - it was all working fine and now I can't get anything to work with the Panasonic TV (except for this Logitech Media Server - which works fine and stream audio and video from the same box to the TV without issue).

    I'm still working on it... but just can't get anywhere. I thought I'd post on here for any sort of help or ideas whilst I continue to scratch my head.

    Any and all help very much appreciated.


  2. #2

    I've gone back to 2.4 - no difference...

    Installed KRR 2.5 on another Win 7 Ultimate SP1 machine - no difference...

    Factory reset my HP ProCurve gigabit switch (core network switch) - no difference...

    Factory reset (much to my annoyance, as there are lots of Pro colour/display settings) my Panasonic TV and set it all up again - no difference...

    Set up a Windows HomeGroup etc. (even though I've never had one or wanted one in the past) - no difference...

    Cleared all KRR firewall rules, reinstalled KRR and checked them (look good) - no difference...

    Fixed IPs, DHCP IPs, tried em all - no difference.... (Xbox One is on DHCP)

    Xbox One can see all of these DLNA servers that I'm setting up to try and help / test - and the Panasonic can still only see the damn Logitech one.

    Going to bed!
    Last edited by MrShades; March 16th, 2015 at 10:17 AM.

  3. #3
    Super Moderator KRR Team's Avatar
    Join Date
    Mar 2014
    Hi MrShades

    The new version has nothing to do with these issues.

    I suspect this relates to networking issues and firewall on your computer.

    I suggest you take off all apps running on the background (including anti virus, you can disconnect your internet if you wish), take down the firewall setting of windows and try again.

    Keep me updated.

  4. #4
    Thanks for the reply - and yes, I appreciate that it's not version (or probably, either KRR) related - as it's happening with KRR (on multiple Win7 machines) and with PS3MS.

    I'm going to look more closely at the damn security and streaming options in Win 7 - as I think the updates or system may have changed these.

    When I'm really stuck then I'll install KRR or PS3MS on a simple XP machine, plug it into the 8 port switch that the TV is on - and see what happens.

    Thanks for the reply anyway... but I agree, I'm looking for Windows 7 gotchas/issues rather than specific KRR issues.

    Will feed back if I find out anything more or get anywhere.

  5. #5
    I tried the simple XP machine running KRR and Twonky - and still nothing.

    So called Panasonic - and they couldnt suggest anything other than an Engineer visit.

    Engineer came about a week ago, and took the TV away... but I've had it back today, with a new mainboard - and it's working fine again!

  6. #6
    Super Moderator KRR Team's Avatar
    Join Date
    Mar 2014
    Glad to hear problem solved with Panasonic...


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts