Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Loading Time

  1. #1

    Loading Time

    Hello,

    I am new to the KooRaRoo Community but it's the best server to have worked with my LG Smart TV LA6418.

    There is only one problem.

    When i watch some Episodes of a TV series over the server i can go forward a minute and or so.

    If I want to go forward just 10 sec then it has a heavy loading time of almost a minute.

    How can i fix this?

    Best Regards
    5ch0lli

  2. #2
    Hello,

    I'm glad you like KRR - thank you!

    Do these episodes that cause a long loading time are of the same type (e.g. AVI or MKV) or is it random?

    Also, please check the Devices pane and let me know which device profile you are using for the TV.

  3. #3
    Hello,

    Thanks for your quick answer!

    The problem is in every episode. the Ending of the file says .mkv but they are just remuxed .avi's.

    Also i noticed the problem today with an .mp4 file.

    I used Default Device and LGTV (2013 Models) ppo4.jpg

    None of both have worked to get a better result.

    Best Regards
    5ch0lli

  4. #4
    Ok, I'll need to see a log to investigate this further.

    Please enable logging by ticking the Enable Logging item under the Tools menu. Then restart the server using the stop/start button on the toolbar and try playing one of those files and reproduce the long loading time. Right after that, stop the server and send in the logs to support (at) kooraroo (dot) com . To find the logs, please go to Tools -> Options -> File Locations and click the Open button on the Logs folder.

    Would you be able to send me one of those problem files as well? I could test it on my LG devices here to see if I can reproduce this (it always makes it easier to fix issues). If you can, please upload it to Dropbox (http://db.tt/lRFZ8DfF) or any other file sharing site.

  5. #5
    I will as soon as i can!

    5ch0lli

  6. #6
    The problem seems to be solved and was kind of own stupidity!

    The hard drive was almost broken. so ow its gone and i have a new one, which is playing the files well and FF and REW (in 10s steps) are working perfect.

    But there is another Problem. I would like to transcode a lot of my files to a special codec which my TV supports, BUT I have to do that manualöly fort every file.

    I know the transcoding profile for my device is choosable at the bottom, but it transcodes very poorly!

    So is there a possibility to change global settings for the transcode process?

    Best Regards
    5ch0lli

  7. #7
    I'm glad you solved the first issue - great!

    With the default encoding for the LG TV - it should transcode to MKV with h264 video. When you say it transcodes poorly, do you mean slowly or the resulting quality is not good? Which codec would you like to encode to?

    It's possible to modify the global setting for encoding by modifying the device profile directly - I'll tell you how to do that once I know which codec you'd like to encode to.

  8. #8
    the resulting quality is not good. But it's rather the sound than the video.

    As I have 5.1 Home cinema System hooked up to the TV with an optical cable the sound comes in mp2, ac3 or mp3 very poorly. It's kind of a muffled sound.
    aac worked fine but i had to tell Kooraroo to manually transcode sound to aac.

    So I would like to have a global profile which uses following:
    matroska, webm
    with h264 (which is the only codec XD)
    and aac 5.1 surround

    Would be great to change it globally so every incompatible file is transcoded automatically to this format.

    Best Regards

    5ch0lli

  9. #9
    Ok, I understand. I'm a bit surprised that AC3 in 5.1 doesn't come out ok, but perhaps it's not being decoded properly by the amplifier.

    To modify the device profile and create a custom one for your particular setup, please do this:

    1) go to Tools -> Options -> File Locations in KRR and click the Open button on the Databases folder
    2) in that folder you'll see KooRaRooDevices.krrx file
    3) open that file using a text editor
    4) find "7126A560-1ABD-4a04-9050-0F19DAFDD32E" in it, which is the ID for the "LG TV" device profile
    5) in that profile you'll see:

    Code:
                    <Format id="matroska" format="matroska,webm" encode="1" default="1" dlnaflags="01700000000000000000000000000000">
                        <Codec id="h264_level51high" minlevel="30" />
                        <Codec id="aac" />
                        <Codec id="ac3" />
                        <Codec id="dts" />
                        <Codec id="mp2" />
                        <Codec id="mp3" />
                    </Format>
    6) delete the <Codec id="ac3" /> line
    7) save the profile, restart the server and the GUI
    8) now KRR will be transcoding to "aac" by default

    Alternatively, you can try changing that format to:

    Code:
                    <Format id="matroska"  format="matroska,webm" encode="0"  dlnaflags="01700000000000000000000000000000">
                        <Codec id="h264_level51high" minlevel="30" />
                        <Codec id="aac" />
                        <Codec id="ac3" />
                        <Codec id="dts" />
                        <Codec id="mp2" />
                        <Codec id="mp3" />
                    </Format>
    and then add a second format like this:

    Code:
                    <Format id="matroska_enc"  format="matroska,webm" encode="1" default="1"  dlnaflags="01700000000000000000000000000000">
                        <Codec id="h264_level51high" minlevel="30" />
                        <Codec id="aac" />
                    </Format>
    What this does it it passed through MKVs natively, but if anything needs transcoding, it'll only transcode to h264/aac.

    Please let me know how that goes.

  10. #10
    Ok,

    as i tried to do this the Tv said the file is not compatible and won't be supported.
    I guess its because of the sound. I think they have a limitation to the .mkv container which says that they only support h264 and HE-aac or Dolby digital.

    but as i understand the database file i can just tell KRR to encode ac3 with 6 channels and a high bitrate. maybe that'll work. shpouln'T be so hard to do.

    added an codec with ID ac3_lg
    Code:
    <Codec id="ac3_lg" codec="ac3" encode="1">
    				<Bitrate>640000|576000|448000</Bitrate>
    				<Samplerate>48000</Samplerate>
    				<Channels>6|5|2|1</Channels>
    			</Codec>
    replaced the standard codec with the one with ac3_lg in the device list

    Code:
    <Format id="matroska" format="matroska,webm" encode="0" default="0" dlnaflags="01700000000000000000000000000000">
    					<Codec id="h264_level51high" minlevel="30" />
    					<Codec id="aac" />
    					<Codec id="dts" />
    					<Codec id="mp2" />
    					<Codec id="mp3" />
    				</Format>
    				<Format id="matroska_lg" format="matroska,webm" encode="1" default="1" dlnaflags="01700000000000000000000000000000">
    					<Codec id="h264_level51high" minlevel="30" />
    					<Codec id="ac3_lg" />
    				</Format>
    will try this asap.

    5ch0lli

    PS: as the support is brilliant I'm thinking of purchasing a copy of KRR. ^^

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •