Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Where to put external SRT subtitle files?

  1. #1

    Where to put external SRT subtitle files?

    Unfortunately, KooRaRoo is not serving up my srt files:

    2012-12-05T15:20:02.091-05:00 [CDBMediaServerDelegate::ProcessFileRequest] (4064) INFO: Url:, path: 0I27I32I1I14
    2012-12-05T15:20:02.091-05:00 [PLT_HttpHelper::ToLog] (4064) INFO: Responding with:
    HTTP/1.1 404 File Not Found
    Date: Wed, 05 Dec 2012 20:20:02 GMT

    Is there a special folder to place the srt files in? It definitely knows the srt file is there because if I delete the srt file from disk, delete and re-add my folder from the KooKaRoo GUI, then the server log shows that KooKaRoo won't even tell the DLNA client that an srt file is available, and therefore the DLNA client won't even send a request for it.
    Last edited by anontemp123; December 6th, 2012 at 06:27 AM.

  2. #2
    The SRT (and other external subtitle files) should be either in the same folder as the movie file or in a folder set via the Options -> File Locations -> Subtitles folder. It should be named exactly the same as the movie file.

    Where is the "" file located in the log example above?

  3. #3
    Quote Originally Posted by Dennis View Post
    Where is the "" file located in the log example above?
    The video file is named "temp.avi" and the "" file is located in the same folder as the video file.

    As I mentioned, when KooRaRoo generates its metadata, it definitely sees that exists as a subtitle file. This is evident from the log. If I delete from disk, then delete and re-add temp.avi from KooRaRoo's media library, KooRaRoo's server log won't even show any requests for from the DLNA client.

    Here's my best guess: The code that generates the media library's metadata does check in the same folder as the video file for a .srt file. This is why KooRaRoo will inform the DLNA client that a subtitle file is available. However, when the client then requests this subtitle file, the code that actually serves the .srt file is either (a) looking only in the Subtitles folder, or (b) getting confused because I have no Subtitles folder specified (so it never gets to the point where it can check the same folder as the video file.)

    I'll try and check these theories later today. Thanks for the reply.

  4. #4
    The subtitles folder in Options is empty by default, so KRR shouldn't be looking there (and shouldn't be confused that it's empty). Can you please also check the file permissions on, just to make sure it doesn't have any restrictions (e.g. limited to a certain user).

    If you are comfortable with looking at databases, you could check the KooRaRooMediaMain.krrx file (it's an SQLite database, the location can be found by going to Tools -> Options -> File Locations -> Databases) and check the stored path for the SRT file, perhaps something is wrong there... Alternatively, please send that file to support (at) kooraroo (dot) com and I'll check it. Please let me know either way.

  5. #5
    I've tried every combination, leaving the subtitles folder empty, specifying a subtitles folder, placing the subtitle file in the same folder as the video file and in the subtitles folder simultaneously, making sure everything is on the C:\ drive, etc. and nothing seems to work. I checked the SQLite database and the Files table lists only the temp.avi file and the ExternalFilestoFile table lists the file. The path is correct.

    I diagnosed further with ProcessMonitor:

    KooRaRoo's GUI definitely checks exists when I add temp.avi to the media library. Oddly, when adding temp.avi to the media library, KooRaRoo will also check for <PathToSubtitlesFolder>\.srt -- yes, exactly the file ".srt" (just the extension, no base filename) in the subtitles folder. Not sure what's going on with that.

    When KooRaRoo receives a request from the DLNA client for, though, it won't even look for a srt file on the filesystem anywhere. The "File Not Found" response seems to be returned before KooRaRoo even accesses the filesystem; somewhere before that would happen KooRaRoo is deciding that the request is for a nonexistent file. Maybe the DLNA client is sending a malformed request? Via the log file, I've copied and pasted into my browser the URL KooRaRoo outputs to XML. Same 404 error. Could you provide some guidance on how to diagnose this further?
    Last edited by anontemp123; December 6th, 2012 at 02:59 PM.

  6. #6
    Thanks for picking up the problem with the subtitles folder - I've now fixed it and a patch is available. I also think I know what the problem with the subtitles could be and perhaps the patch will fix it as well.

    Please send an e-mail to support (at) kooraroo (dot) com and I'll send you the patch to try.

  7. #7
    I sent an email to support. Do I need to login to the support system to proceed?

  8. #8
    Quote Originally Posted by anontemp123 View Post
    I sent an email to support. Do I need to login to the support system to proceed?
    Thanks - I've received it and uploading the patch right now. I'll let you know once it's ready for download.

    The system works both ways - through e-mail or through the online support portal, so whichever way you choose is fine.

  9. #9
    The patch seems to fix the problem. With some formats/resolutions, my DLNA client won't send a request for the SRT file even though I can see KooRaRoo has informed the client the SRT file is available. That is likely an issue with my DLNA client. I'll report back after further testing.

  10. #10
    Great, thanks for letting me know! Which device are you using, perhaps I can do some testing as well?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts