View Full Version : Phillips TV 6000 Series, don't show Arabic or Persian subtitle

March 9th, 2014, 05:21 PM
Hello, I have a FPL6008(Phillips TV 6000 Series) and I'd like to show my movies with Persian subtitle by below configurations:

===Device Definition===
01- Checked "Device" and select "Phillips TV 6000-series".
02- Checked "Enable burned-in subtitles'.
03- Set Encoding "Unicode (UTF8)" or "Arabic (1256)" because I can have UTF8 and ANSI(1256) subtitle files.
04- Select "Tahoma" font and click "Generate Font Cache".
05- Checked "Transcoding Incompatible Files".

01- Checked "External subtitles codepage" to "Unicode (UTF8)" or "Arabic (1256)".

===File Properties===
01- In "Available Subtitles" my SRT loaded.
02- I selected "Unicode (UTF8)" or "Arabic (1256)".
03- Put 'per' for "Language" parameter.
04- Click "Update" button and can see:
[Script Info]
ScriptType: v4.00+

[V4+ Styles]
Format: Name, Fontname, Fontsize, PrimaryColour, SecondaryColour, OutlineColour, BackColour, Bold, Italic, Underline, BorderStyle, Outline, Shadow, Alignment, MarginL, MarginR, MarginV, AlphaLevel, Encoding
Style: Default,Tahoma,16,&Hffffff,&Hffffff,&H0,&H0,0,0,0,1,1,0,2,10,10,10,0,0

Format: Layer, Start, End, Style, Text

Also show my subtitle text correctly...

===Get File Information===
Video, DB: 1, Thumb: 0
S [h264, 28], bitrate: 0, framerate: 23.98, level: 41, profile: 100, flags: 0x0, flags2: 0x0


ffmpeg version N-59852-g785dc14 Copyright (c) 2000-2014 the FFmpeg developers
built on Jan 15 2014 14:14:41 with gcc 4.8.0 (GCC)
configuration: --disable-shared --enable-static --arch=x86_64 --target-os=mingw32 --cross-prefix=/home/dennis/cc/mingw-w64-x86_64/bin/x86_64-w64-mingw32- --pkg-config=pkg-config --enable-gpl --enable-libx264 --enable-avisynth --enable-libxvid --enable-libmp3lame --enable-version3 --enable-zlib --enable-libopenjpeg --enable-libfreetype --enable-fontconfig --enable-libass --disable-w32threads --enable-bzlib --enable-libbluray --enable-dxva2 --enable-memalign-hack --enable-avresample --enable-runtime-cpudetect --extra-cflags=-DPTW32_STATIC_LIB --enable-libvpx
libavutil 52. 62.100 / 52. 62.100
libavcodec 55. 48.101 / 55. 48.101
libavformat 55. 23.103 / 55. 23.103
libavdevice 55. 5.102 / 55. 5.102
libavfilter 4. 1.100 / 4. 1.100
libavresample 1. 1. 0 / 1. 1. 0
libswscale 2. 5.101 / 2. 5.101
libswresample 0. 17.104 / 0. 17.104
libpostproc 52. 3.100 / 52. 3.100
Input #0, matroska,webm, from 'E:\S01E01.mkv':
encoder : libebml v1.0.0 + libmatroska v1.0.0
creation_time : 2011-04-18 12:31:44
Duration: 01:01:35.23, start: 0.000000, bitrate: 901 kb/s
Chapter #0.0: start 0.097000, end 3695.232000
title : 00:00:00.097
Stream #0:0: Video: h264 (High), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Stream #0:1: Audio: aac, 48000 Hz, stereo, fltp (default)
At least one output file must be specified

FINALLY after "Play To Device" subtitle doesn't shown!


A. What is wrong?

B. Does Kooraroo support subtitile without transcoding?

Thank You

March 10th, 2014, 07:09 AM
It all looks correct. Can you please try playing that file from the TV (do not push it to the TV from the GUI, but use the TV to find this file and start playing it) and see if that works - please let me know.

KooRaRoo does support sending external subtitles without transcoding, if your TV supports those. The device profile shows that the 6000-series should support SRT subtitles - if you disable burned-in subtitles, do you get subtitles on the TV?

March 11th, 2014, 03:13 AM
Hello, Thank you for reply.

But does not shown subtitle also! :( any suggestion?

How I can disable tarnscoding permanently? my movies play from USB (without conversion) and because the TV does not support windows-1256 character set so I have to use DLNA but it tarnscoding every time! whay? maybe after disable transcoding subtitle will be display.

I want to read the TV manuals to find out: Can my TV support "external subtitles without transcoding" so what is named?


March 11th, 2014, 06:55 AM
Have you disabled the burned-in subtitles? If you have and the SRT file does not come, then we need to check the logs. Please enable logs by ticking the Enable Logging item under the Tools menu. After that restart the server using the stop/start button on the toolbar and try playing that video on the TV for a few seconds. After that stop the server and send the logs to support (at) kooraroo (dot) com. To find the logs please go to Tools -> Options -> File Locations and click the Open button on the Logs folder.

March 12th, 2014, 05:34 AM
As I know Philips (TP Vision) does not support .srt over DLNA so transcoding is a must. But you should try this settings:
KRR-Tools-Options-Advanced-External subtitle codepage-Arabic(1256) and UTF-8 for device. Thats what worked for me.

March 12th, 2014, 06:23 AM
As I know Philips (TP Vision) does not support .srt over DLNA so transcoding is a must. But you should try this settings:
KRR-Tools-Options-Advanced-External subtitle codepage-Arabic(1256) and UTF-8 for device. Thats what worked for me.

Thank you for your suggestion, but I tested Charachter-Set properties as before and does not affected on the problem :(

Do you have official and clearly document about "does not support .srt over DLNA" by this TV?

March 12th, 2014, 06:29 AM
... and send the logs to support (at) kooraroo (dot) com...

Hello dear Dennis, requested Log file mailed to specified address and also available .:Here:. (http://qkup.net/6cl5rzs7sbf8/KooRaRooMediaServerLog_2014-03-11-23-30-15.txt.html)


March 12th, 2014, 08:08 AM
Thanks for the logs - I'll get back to you via support.

March 20th, 2014, 07:44 PM
Thank you for reply.

Finally, I accepted my device is not supported subtitle over DLNA without transcoding.

So I want show subtitle by transcoding and checked "Enable burnned-in subtitles" but subtitle does not shown on TV :(
the Media Renderer & Transcoding & Burnned-in subtitles are enabled(screenshot (http://www.uploadax.com/images/51786078043472604899.jpg))

NOTE: I used Universal Media Server (http://www.universalmediaserver.com/) application(It's free) and subtitle shown by live transcoding on my TV, so I think it can/will be possible for me by Kooraroo too, right?!

My question:

1. Why two devices detect on "Device panel"? (screenshot (http://www.uploadax.com/images/76554120649174209910.jpg)) It's my TV's issue or the kooraroo's issue? which one settings will be applied?

2. Why my settings in "Edit file properties" does not saved?


Because I'm a software developer(like you) so I have many questions usually ;) Thank you.

March 22nd, 2014, 08:16 PM
Thanks for the screenshots!

The first issue that I see from the Devices panel screenshot is that the "Default Device" device profile is being used for both devices. Please double-click on both of those and select the "Philips TV 6000-series" device profile. There shouldn't be two entries there, but let's look at that later - for now just change the device profile for both and see if that makes subtitles work.

With the subtitle settings - are you clicking the "Update" button after you change the setting? If not, then that would be reason why the setting is not saved.