View Full Version : Android failed to play

December 17th, 2013, 08:21 AM
Tried using KooRaRoo v2.2 on Windows 8.1 with the app "Twonky Beam" on an Android 4.2.2 tablet (Galaxy Tab 3). It fails to play or to cast to another renderer (TV).

I noticed the transcoding directory created by KooRaRoo used the word "pal" in it's name, and not the "ntsc" that is used here in USA.

I believe this is the directory created for a mp4 file I was trying to serve up ...

......\KooRaRoo_Transcoding\mpeg2_mpeg2_pal_00_ac3 _01_00

I also have a Win7 partition on the same machine and was able to get the same file to play there without the use of KooRaRoo.

Your product works fine serving up the file to a Sony BluRay player I have in the house but creates the directory ...
......\KooRaRoo_Transcoding\mpegts_mpeg_h264_level 41high_00_aac_01_00

Is there anything I can do to make this work?
Is there a better Android app that you'd recommend?
Any other info you need from me?


December 17th, 2013, 11:11 AM

I am not sure what formats Twonky Beam supports, but many people use MX Video Player with Bubble UPnP and that works well. You'd need to select the "MX Video player" device profile for it in KooRaRoo (through the Devices pane). Most files can be streamed natively without transcoding.

With Twonky, most likely KRR is using the default profile, which is not optimized for mobile devices. When passing through contents to another device (TV), you'd need to set the device profile for that TV in KRR for the tablet's IP address - this is so KRR can deliver files formatted correctly for the TV (typically an app that passes contents through does not tell KRR what the end device will be, so that's why you need to set the profile manually).

August 18th, 2014, 02:02 PM
Sorry to dig up such an old thread but it represents my issue pretty darn well. Multiple android devices can see the content being advertised by Kooraroo, but refuse to play any of it. I've tried multiple DLNA clients (by default I use BubbleUPNP) and multiple video players (again defaulting to MX Player), but no content will ever start playing. All of my videos are MKV format, either DVD rips via handbrake, or BD rips via PavTube. I can connect and play them with other devices, but android eludes me. Mind you, I have been able to stream using other DLNA servers in the past, but I am trying to standardize on Kooraroo.

I've configured the client as both "MX Player" and "MX Player Compatible". I've tried SW, HW and HW+ on the android devices. I've installed the ARM CODEC and ARM-NEON CODEC.

Tried it with transcoding enable and disabled.

Kind of at wits end here. And ideas would be really appreciated!


KRR Team
August 20th, 2014, 12:45 AM
Hello Krizzz,

Welcome to the forum, and sorry for this problem. Normally BubbleUPNP with MX Player works just fine. Could you please try streaming some other video format (not MKV) and see if it works.


September 11th, 2014, 06:39 AM
See my post under suggestions, I am able to play all Krr content on my Samsung Tab 3


KRR Team
September 11th, 2014, 12:57 PM
Thank you for sharing your experience alback.