PDA

View Full Version : Disable Transcoding in general



minorum
October 29th, 2013, 07:53 PM
Hi,

at the moment I test KooRaRoo and I quite like it.
I found the settings for devices to disable transcoding.
We do get quite a number of visitors and I would like them to use the streaming service. On the other hand I don't want to put strain on the server for transcoding,for it is not a very powerfull computer.
So is there a possibilty to switch off transcoding in general? That would be very usefull, for I like to connect new users directly without asking.

greetings

minorum

Dennis
October 29th, 2013, 09:53 PM
Hi,

I'm glad you like KooRaRoo - thank you.

There is no global "disable transcoding" option at the moment (although it is planned). What you can do instead is manually modify the device profiles file and leave just one profile in there with disabled transcoding, if that works in your particular circumstances. I'd be happy to walk you through it or discuss other ways to solve this here or through the support portal.

minorum
October 29th, 2013, 10:04 PM
Thanks,

that sounds like a resonable workaround. So where do I find the "device profies file"?
I will test the programm another couple of days but it looks as I am going to order it. :-)

greetings from germany

minorum

Dennis
October 30th, 2013, 07:10 AM
The device profiles files is called KooRaRooDevices.krrx (it's just a text file) and to find it, go to Tools -> Options -> File Locations and click the Open button on the Databases folder.

You can then delete all profiles from it (make a copy of the file first, just in case), except one (for example, leave "A.C.Ryan" in there). In that one remaining profile set all encode="1" to encode="0" and this will disable transcoding for the whole profile. Also, set its ID to be ID="0", like so:

<Device ID="0">

This will then make KRR load this profile for any connected device and since all formats have encode="0", it won't try to encode any incompatible files.