PDA

View Full Version : Feedback on interop with Yamaha RX-A3030



boxerfan88
October 23rd, 2013, 11:44 PM
Hi,

Stumbled on the KooRaRoo DLNA server. Impressive software!

Just to give you feedback that the version 2.1 cannot stream FLAC to the Yamaha RX-A3030. The AVR reports error. Tried both AVR pulling from KooRaRoo, or KooRaRoo initiating using "Play To". FYI, the RX-A3030 supports FLAC decoding.

Does not matter if transcoding is set enable/disabled. Wont work.

As reference - PLEX media server can stream the same FLAC file to the RX-A3030. Hope u can fix it.

Cheers.

Dennis
October 24th, 2013, 07:59 AM
Hi,

Thank you for the positive feedback on the overall operations - I'm sure we can make FLAC going there.

First, can you please check that the device profile selected for the receiver is correct? To do that, please go to Devices pane and see what it says there in "Device definition". If it's not correct, please double-click on the device and select a Yamaha profile and see if that helps. If not, we'll work it out.

boxerfan88
October 24th, 2013, 08:45 PM
Device definition is "Yamaha AVR".

I turned on the logging, then attempted to play 1 file, then stopped logging. Found this wierd error (the file does actually exist in that path). Is the full file path too long?



2013-10-23T22:27:51.375+08:00 [PLT_HttpHelper::ToLog] (9124) INFO: Responding to:
GET /0I0I30I1I10D2 HTTP/1.1
Host: 22.22.22.88:53180
Icy-MetaData: 1
Connection: close
transferMode.dlna.org: Streaming
User-Agent: WinampMPEG/2.8
Accept: */*

2013-10-23T22:27:51.378+08:00 [CDevices::GetDeviceIPMac] (9124) INFO: Device not found in DB with IP: 22.22.22.8 and MAC: 00:a0:de:a3:88:99
2013-10-23T22:27:51.378+08:00 [CDBConfig::GetDeviceDB] (9124) INFO: 22.22.22.8, 00:a0:de:a3:88:99, []: 0
2013-10-23T22:27:51.378+08:00 [CDBConfig::GetDeviceDB] (9124) INFO: Found device with IP: 22.22.22.8 [RX-A3030 A38899]
2013-10-23T22:27:51.378+08:00 [CDBMediaServerDelegate::ProcessFileRequest] (9124) INFO: Url: http://22.22.22.88:53180/0I0I30I1I10D2, path: 0I0I30I1I10D2
2013-10-23T22:27:51.379+08:00 [CDBMediaServerDelegate::ProcessFileRequest] (9124) INFO: Responding with native file (device definition: F6F66A09-916D-48e9-8AF2-8C3784508460, Yamaha AVR): D:\MUSIC\FLAC\Air Supply - The Definitive

Collection (1999) (Remastered) - FLAC\1 - Lost in Love.flac
2013-10-23T22:27:51.379+08:00 [CDBMediaServerDelegate::BuildHeader] (9124) INFO: st: 0, bh: 0, it: 10, bgasr: 0
2013-10-23T22:27:51.379+08:00 [CDBMediaServerDelegate::BuildHeader] (9124) INFO: Found transferMode: Streaming
2013-10-23T22:27:51.379+08:00 [CDBMediaServerDelegate::ServeFile] (9124) INFO: File: 1, device: 2
2013-10-23T22:27:51.379+08:00 [CDBMediaServerDelegate::ServeFile] (9124) SEVERE: File does not exist: D:\MUSIC\FLAC\Air Supply - The Definitive Collection (1999) (Remastered) - FLAC\1 - Lost in Love.flac
2013-10-23T22:27:51.379+08:00 [PLT_HttpHelper::ToLog] (9124) INFO: Responding with:
HTTP/1.1 405 Bad Request
Content-Type: audio/flac
Connection: close

Dennis
October 24th, 2013, 09:08 PM
Is D: a NAS drive? Perhaps it's a folder permissions issue - please see if this thread helps if that's the case: http://forum.kooraroo.com/showthread.php/2040-Cannot-play-files-from-your-NAS-but-they-work-from-a-local-drive

Please let me know.

boxerfan88
October 24th, 2013, 10:06 PM
Nope, local HDD (D:) on the same computer where KooRaRoo is installed.

boxerfan88
October 24th, 2013, 10:16 PM
More info. I found a couple of test .AC3 and .DTS files, and placed it on the drive, it works (KooRaRoo can PlayTo the Yamaha AVR)! The problem is narrowed to FLAC only it seems.

boxerfan88
October 24th, 2013, 11:01 PM
Dennis, thanks for the pointer, it was permission issue after all!

Dennis
October 25th, 2013, 08:10 AM
I'm glad you've sorted it out! Local drives are less likely to have permissions issues, but they do happen of course.