PDA

View Full Version : DVD .iso with 1.9.0



mugsy
September 21st, 2013, 12:48 AM
Hi there,

I just installed KRR to manage my media collection and make it available to Android tablets. The handling of MP3s and JPGs is working great. Part of my collection is a number of DVD .iso which causes some issues. KRR detected them fine but does not seem to pick the correct main title within the disk. Often it shows a much smaller runtime than the actual main title. In addition, when browsing the DVD collection using either BubbleUPnP or MediaHouse on the tablet, I cannot see entries with "(main title)", only a single entry per .iso image. Finally, when selecting on the tablet an entry which was detected with the proper runtime, it fails to start streaming to MX player (selected MX Player (compatible) as device type, plays back other video files correctly).

So questions:
- When KRR starts streaming a DVD which needs to be transcoded, does KRR need to transcode the whole title before streaming? I understand that until a title is fully transcoded one cannot fast forward or jump beyond the transcode point but as long as the server can transcode in real time or faster, the video can be streamed to the renderer for playback.
- When KRR fails to properly detect the main title, is there a way to override which is the main title?
- How do I get KRR to show all of the titles in an .iso image, including the main title?

Thanx,
Mugsy

Dennis
September 21st, 2013, 09:25 AM
Hi,

Actually the "(main title)" is only applicable to DVDs in the form of .VOB files in a VIDEO_TS folder. .ISO files are not currently parsed for titles, but this planned in one of the next updates. What should happen now is that .ISO files are played from start to finish. Typically, they contain menus in the front, so you should be able to FF past those or just let them play through and it should then get to the main title.

If this is not the case and/or you cannot play the file at all, we'll need to investigate and logs will the first thing to look at.

To enable logging please tick the Enable Logging item under the Tools menu. After that restart the server using the stop/start button on the toolbar and restart the GUI. Then try playing one of the failing ISO files using MX Video player and send me a log for that to support (at) kooraroo (dot) com. We'll then work it out.