View Full Version : Sony BDP-S470 "no playable file" & XBMC not detected

September 2nd, 2013, 11:38 PM
Hello. I've been test driving the free KRR for a few days now and really like it's ability to handle playlists for music. I'll consider purchasing the full version, but I've got two hangups to get through first.

I run a windows home server on a 2.8g P4 dell SOHO server with 2g of RAM. All of my media and other pc backups are there. Everything media related is hard-wired, no wireless in this distribution. My goal is to serve video to a Sony BDP-S470 BluRay player in the main TV system and serve music to a PC in the garage running Ubuntu and XBMC. I've been using Serviio for a while and it is the only dlna server that I have found to serve video successfully to the Sony. The problem with Serviio is that it doesn't handle music playlists worth a damn. I've used Firefly DAAP server for music for a while, but it's dynamic playlists never updated once created. PS3 media server doesn't show up on the Sony at all. So, now I'm trying KRR.

I've found the Sony in the devices list, and adjusted the profile to all of the Sony BDP choices. I can see KRR from the Sony, and drill down the folders, but once I get to files, I get the dreaded "There is no playable file" message. Any thoughts?

Also, I've found that KRR found my XBMC devices once, but they seem to have vanished and have not returned even with multiple refreshes and server reboots. I thought those were renderers that could be remote controlled, but they haven't shown up in the 'play to device' list ever.

Aside from those concerns, I really dig the GUI!

September 3rd, 2013, 08:24 AM

Thank you - I'm glad you like KRR and I'm sure we'll get it going.

The two most common issues with that error message is a) the file format is not suitable for the device and a different device profile is needed or b) the files are located on a NAS drive and the server doesn't have permissions to access them. From what I understand, you keep your media on a local disk on the PC, right? In that case, it sounds like an incorrect format issue.

For the second issue I already have a patch available through support.

The best way to proceed would be for me to see some logs. So, please enable logging by ticking the Enable Logging item under the Tools menu. After that use your BDP to browse to a file that fails to play and try playing it. After that stop the server, zip up the logs and send them to support (at) kooraroo (dot) com . To find the logs, please go to Tools -> Options -> File Locations and click the Open button on the Logs folder.

This will create a support ticket in the system and I'll also send you a patch to fix XBMC disappearing from the renderers list.

September 5th, 2013, 09:17 AM
Super. Thanks, Dennis. I just sent the log files. I tried a video / movie, then successfully played some audio, then tried a movie again. Interesting that I can see files in the folders when perusing music, but not the same for video...

September 5th, 2013, 10:23 AM
Thank you for the logs. I actually thought that you couldn't play music, so it's good that I saw your reply here before I sent you my reply via support. I'll get back to you shortly.