PDA

View Full Version : How to use the burned-in subtitles feature



Dennis
January 14th, 2013, 09:27 AM
By default your external subtitles will not be burned-in, so to enable this feature for your device please follow these steps:

1) go to Devices pane
2) double-click on the device you wish to enable burned-in subtitles for to bring up the properties
3) in the dialog that comes up go to the Subtitles tab
4) tick the "Enable burned-in subtitles" box
5) optionally set the subtitles language priority (it works in the same way as the audio language priority)
6) set the font style, size and color to suit your device and personal preferences
7) click OK to apply - you'll get a question regarding the fonts cache, if it hasn't been generated yet (this is done only once)

Now try playing your video with external subtitles on the device, it should now be transcoded and you'll see subtitles.

You can reload the subtitles into the database by right-clicking on one ore more files and selected Reload from disk -> Subtitles (this is useful if you change/rename subtitle files and don't to update the whole folder).

You can also use the manual Transcode feature, which will allow you to manually set a specific external subtitle file (based on the type and language).

hcpr7
January 27th, 2013, 07:22 PM
Hello
I can't see burned-in greek subtitles correctly (I see "?????????????") in my SONY BRAVIA KDL-40EX720.
I tried many different fonts but my problem is not solved.
Any suggestion?

Thank you.

Dennis
January 27th, 2013, 07:26 PM
Hello,

Yes, most likely the problem is with the encoding of the subs. The upcoming release 1.4.1 fixes this problem - please send an e-mail to support (at) kooraroo (dot) com and I'll send you a patch to try.

hcpr7
January 28th, 2013, 05:51 AM
Thanx Dennis!
It works perfect!!!

Dennis
January 28th, 2013, 07:58 AM
I'm glad that worked - thanks for letting me know!

Mibber
February 11th, 2013, 11:25 PM
Hello,

I'm using the trial version of KooRaRoo (version 1.4.1.0) and don't seem to get this to work.
I've double clicked on the device (a philips 40pfl8007 tv) and enabled the burned-in feature. The profile of the TV is set to the 8000-series profile for Philips tv's.

In the folder of the movie (I:\movies) I'm trying to stream I've added an .srt subtitle file with the exact same name as the movie file.
The subtitle doesn't show up, and in KooRaRoo I don't see the subtitle file next to the MKV file.

Are there any other settings I need to enable to get this to work?

Dennis
February 11th, 2013, 11:55 PM
No, sounds like you've enabled everything that needs to be. Subtitles won't show up in the folder listings, but there is a way to see them (see below).

Did you add the SRT before or after adding the movie to KRR? If the latter, then you need to right-click on the file and use Reload -> Subtitles command.

Also, one way to check if your subtitles are loaded is to right-click on the video file, then select Transcode. In the dialog that comes up, see if "Burn-in external subtitles" box is enabled. If it is, then external subtitles have loaded. If it's disabled, then they haven't and there's some issue with the files or something else.

If that doesn't help, please open a support ticket via http://support.kooraroo.com and send in your SRT file, so that I could check if there's any issue with it.

alb
April 1st, 2013, 06:28 PM
Hi,

I just started using Kooraroo and I have a problem with the burned-in subtitles. All my srt files seem to be encoded in ISO-8859-1 (normal media players like GOM Player or VLC display them correctly), but when using Kooraroo to play a movie with the burned-in subs feature on my TV, some characters are not displayed right (e.g. '' is displayed as '�'). Might it be that Kooraroo opens these files as UTF-8? What would be the best solution?

Thanks in advance.

Dennis
April 1st, 2013, 10:21 PM
I just started using Kooraroo and I have a problem with the burned-in subtitles. All my srt files seem to be encoded in ISO-8859-1 (normal media players like GOM Player or VLC display them correctly), but when using Kooraroo to play a movie with the burned-in subs feature on my TV, some characters are not displayed right (e.g. '' is displayed as '�'). Might it be that Kooraroo opens these files as UTF-8? What would be the best solution?

Hi,

Can you please send one of those SRT files through http://support.kooraroo.com and I'll check it here. Did you try setting the encoding charset in the subtitle properties in KooRaRoo?

alb
April 2nd, 2013, 04:08 AM
Hi,

Thanks for the response. I just sent an example file to support@kooraroo.com (subject: example of SRT file in ISO-8859-1 encoding). I'm sorry, I started using Kooraroo last night and I am not yet very familiar with the menus yet. How do I set the encoding charset for the subtitles? Is it in the device properties -> subtitles tab? There I can only see language priority, font, size, color, and a codification textbox which allows me to insert a number, but no encoding charset names.

Dennis
April 2nd, 2013, 09:24 AM
I just sent an example file
Great, thanks! I'll take a look at it and get back to you via e-mail on that.

How do I set the encoding charset for the subtitles? Is it in the device properties -> subtitles tab? There I can only see language priority, font, size, color, and a codification textbox which allows me to insert a number, but no encoding charset names.
Yes, that's the one - the charset is not a name, but rather a code page number, sorry for the confusion. The numbers are listed on this page: http://en.wikipedia.org/wiki/Code_page - let me know if you are not sure which one to use and I'll help you out.

alb
April 2nd, 2013, 06:31 PM
Yes, that worked. I was not aware of the code page numbers. I set the code for ISO-8859-1 and it worked fine.

Thanls a lot!

Dennis
April 2nd, 2013, 07:33 PM
Great, I'm glad that worked!

David
April 5th, 2013, 08:35 AM
Dennis:

Shouldn't that code be the standard one set for the software, instead of 0?

- David

Dennis
April 5th, 2013, 09:11 AM
David,

The code page is really person-dependent, as someone could be running English Windows, but wanting subtitles in Greek (or vice-versa), so if the code page would be retrieved from the system, it may not be correct. I am open to discussion on this though - so if you feel the code page of Windows is close enough, I can make that the default, sure :)

David
April 5th, 2013, 02:37 PM
David,

The code page is really person-dependent, as someone could be running English Windows, but wanting subtitles in Greek (or vice-versa), so if the code page would be retrieved from the system, it may not be correct. I am open to discussion on this though - so if you feel the code page of Windows is close enough, I can make that the default, sure :)

Good call Dennis. KKR could detect the default windows language and set the matching code page as the default. So, for English windows, the English code page would be the default code page selected. If one want to change the default, then they can then select anew page through a drop down menu(?) and have it stored as the new default.

- David

Dennis
April 6th, 2013, 01:08 AM
I'll look into optimizing this.

m5114
September 15th, 2013, 10:07 AM
Hi Dennis,

Thank you very much for such an easy-to-use software for people with limited knowledge like myself.

I downloaded the trial version of Kooraroo earlier today and had no problem in transfering picture/music files & camera clips to my TV. However, I got really confused and frustrated when it came to playing movies with subtitles and that's why I wrote my post in this thread.

First of all, I wanna say that my movie folder is well-organised, with each subfolder including one movie file and one subtitle file (Turkish subtitle files, all in .srt format), both having the same file name.

When I first ran the software, I went through each menu, I left the subtitle encoding as "Default" in tools/options/advanced window. I also went to devices, selected my TV, then went to subtitles tab, enabled burned-in subtitles, and left "Default" setting for subtitle encoding there as well. I played one movie and its subtitle worked perfectly, but then I selected another movie and saw its subtitle showing different symbol for each Turkish character.

Then I decided to change encoding to "Turkish (1254)" in both locations I mentioned above. First subtitle which worked perfectly with "Default" setting showed 3-4 symbols per one Turkish character, which made it almost impossible to follow, and the subtitle of the second movie didn't show anything at all. When I switched back to "Default" encoding, all came back to the previous state as I explained at the beginning, then I tested a third movie and its subtitle ran with interruptions, like it showed one line but showed nothing for a few minutes, then showed another line and nothing for couple of minutes etc...

But I got no problem when I play these files locally.

I've also got an inquiry about transcoding; I play one file and I see both streaming & transcoding working on the status window, and they both stop when I stop the file. But playing/stopping another file and transcoding still continues there and when it finally hits 100% I cannot see where it's stored, or what to do even if I find it.

Thank you in advance,

Mete.

Dennis
September 15th, 2013, 11:28 AM
Hi Mete,

Thank you for the positive feedback and I'm sure we'll get you up and running.

There have been numerous improvements in the subtitles engine for the upcoming version of KRR, so I would recommend that you open a support ticket and I'll send you the latest pre-release version to try along with some pointers on what to set up. Let's see if that works properly.

Transcoding will continue until it's done, but if you start playing a file while another is being transcoded, that first one will pause until the newer transcoding finishes and then it will resume. Transcoded files are stored in a folder that can be moved using Tools -> Options -> File Locations. You can also check individual transcoded files by double-clicking on the original file in KRR to bring up its properties and then going to the Transcoding tab.

m5114
September 18th, 2013, 09:42 AM
I would like to thank you Dennis, for dealing with my inquiry here in this forum, and returning to my support tickets quick and effectively. The pre-release version, which you sent me resolved all my problems.

Have to admit, too excited with the new features :)...

Dennis
September 18th, 2013, 10:10 AM
I appreciate your positive feedback and I'm glad it's all working now - thank you for letting us know!